Jump to content
  • 0
Sign in to follow this  
Railman0z

Problem with launching server and client

Question

Hello guys,
I would like to start this topic by saying that I'm sorry for mistakes in this topic. I'm from Latvia and I'm doing my best on writing this topic. :)
So... Today I was interested in making own RuneScape Private server and coding it ,but I got some problems with launching an Server client and some little error in Server launching. I have download RSPS Server and Client with 637 revision and have launched server without problems (except some little error with NPC's) ,but then I wanted to check server by launching server client ,but it didn't started and showed me an error:

[CODE]Exception in thread "main" java.lang.UnsupportedClassVersionError: RunClient : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source)
Press any key to continue . . .
[/CODE]

I really hope that you understood my problem and will help. :) Edited by Railman0z

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
[quote name='storm powner']download never java version[/QUOTE]

Download newer version of java from oracle.

Share this post


Link to post
Share on other sites
  • 0
I already have installed the newest version of Java and JDK ,but still problem isn't solved. :/
I have readed in other problems that I must recomplie ,but then I got some problems with compiling. It wasn't working because file path was wrong ,but then I changed to correct path and now it's showing :

[CODE]'"C:\Program Files (x86)\Java\jre1.8.0_25\bin\javac.exe"' is not recognized as a
n internal or external command,
operable program or batch file.
Press any key to continue . . .[/CODE]

Share this post


Link to post
Share on other sites
Sign in to follow this  

×