Jump to content
  • 0
ipk4areason

After Jarring PI - Won't open

Question

hello there.

So i ran into an issue, after I jar my PI/ Using NR source and client. It wouldn't open. I tried double clicking but won't open.

Any tips?

Or anybody who had this issue and had it correctly fix?

I've used many other clients and their seem to work. Idk why this one doesnt.

thanks!

add on skype if you can help

ayye.geo

Share this post


Link to post
Share on other sites

40 answers to this question

Recommended Posts

  • 0
Have you included all the class files and put the main loading file (generally client.java) as manifest?

Share this post


Link to post
Share on other sites
  • 0
Wrong class path.

Share this post


Link to post
Share on other sites
  • 0
[quote name='ipk4areason']hello there.

So i ran into an issue, after I jar my PI/ Using NR source and client. It wouldn't open. I tried double clicking but won't open.

Any tips?

Or anybody who had this issue and had it correctly fix?

I've used many other clients and their seem to work. Idk why this one doesnt.

thanks!

add on skype if you can help

ayye.geo[/QUOTE]

make a run.bat and use that to run the jarred client and put a pause at the end, should show you what the error is.

[quote name='samar']Wrong class path.[/QUOTE]

your level of stupidity amazes me sometimes.

>runs and compiles the client.
>jars the client using jarsigner and keytool
> wouldn't be able to do either with invalid classpaths
> samar: yep your classpaths are fucked.

l2java

Share this post


Link to post
Share on other sites
  • 0
[QUOTE]make a run.bat and use that to run the jarred client and put a pause at the end, should show you what the error is.
[/QUOTE]


Within the Jarmaker it allows me to generate a .bat file for it.
and within it I putted it as you said but it just states "press any key to continue"


[QUOTE]Have you included all the class files and put the main loading file (generally client.java) as manifest?[/QUOTE]

i did put client.java correctly already as well =(.
everything was set correctly... idk why could it be some of my files? or that it has a null on it? Any tip?


thanks! Edited by ipk4areason

Share this post


Link to post
Share on other sites
  • 0
[quote name='ipk4areason'][quote name='officiallulzs3c']make a run.bat and use that to run the jarred client and put a pause at the end, should show you what the error is.

Within the Jarmaker it allows me to generate a .bat file for it.
and within it I putted it as you said but it just states "press any key to continue"[/QUOTE]

did you put the pause at the end ?

if so did it show any errors in the run.bat

Share this post


Link to post
Share on other sites
  • 0
[quote name='officiallulzs3c'][quote name='ipk4areason']

did you put the pause at the end ?

if so did it show any errors in the run.bat[/QUOTE]


I did, no errors.

i inserted.

[QUOTE]@echo off

pause
[/QUOTE]

Share this post


Link to post
Share on other sites
  • 0
Make sure your main file is correct, and make a separate file for your client class files and import that to your jar maker.

Share this post


Link to post
Share on other sites
  • 0
[quote name='ipk4areason'][quote name='officiallulzs3c']


I did, no errors.

i inserted.[/QUOTE]

pm me your [B][U]uncompiled[/U][/B] client in .zip format and il have a go

Share this post


Link to post
Share on other sites
  • 0
Personally I don't know why but my Jars won't open on my desktop unless I sign them. May or may not work for you.

Share this post


Link to post
Share on other sites
  • 0
[quote name='MaxiPad']Personally I don't know why but my Jars won't open on my desktop unless I sign them. May or may not work for you.[/QUOTE]

some anti-viruses block unsigned jars because there determined to be malicious as there not from a "reputable source" (reputable meaning anyone who can be arsed signing the jar with useless shit"

antivirus/windows defender logic

Share this post


Link to post
Share on other sites

×