Jump to content
  • 0

Question

Basically I've been trying to get the webclient up and running to no prevail. It keeps on giving a java error and I've tried looking at tutorials however they all use the same method. If anyone could tell me why this could be happening I would be most grateful. On a side note I have turned my java security settings down and even allowed on the java control panel to no prevail.

If you need to look at the webclient or whatever, then it's here: [url]http://project-hallucination.com/webclient.html[/url]

Any help appreciated, Thanks.

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0
Are you running on Windows 8 and/or 8.1?

Share this post


Link to post
Share on other sites
  • 0
Can you give us the error print?

Share this post


Link to post
Share on other sites
  • 0
[quote name='Hope']Can you give us the error print?[/QUOTE]

^ that as well.

Share this post


Link to post
Share on other sites
  • 0
I'm running windows 7. So neither. But here's the error:

Java Plug-in 10.51.2.13
Using JRE version 1.7.0_51-b13 Java HotSpot(TM) Client VM
User home directory = B:\Users\Dinny
----------------------------------------------------
c: clear console window
f: finalize objects on finalization queue
g: garbage collect
h: display this help message
l: dump classloader list
m: print memory usage
o: trigger logging
q: hide console
r: reload policy configuration
s: dump system and deployment properties
t: dump thread list
v: dump thread stack
x: clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------
Missing Application-Name manifest attribute for: [url]http://project-hallucination.com/@ProjectHallucinationWebClient.jar[/url]
Missing Permissions manifest attribute in main jar: [url]http://project-hallucination.com/@ProjectHallucinationWebClient.jar[/url]

Share this post


Link to post
Share on other sites
  • 0
I'm assuming you're using JARMaker, since that's what most tutorials post about. The permissions error most likely comes if you're using a Java update more recent than 7u51.

In the JarMaker, there's a button "Manifest Template", and at the bottom there's an area called Manifest Result. It should have something like
[code]
Main-Class: yourmainclass
[/code]
add this below the Main-Class line:
[code]
Permissions: all-permissions
[/code]

Again, since the new security update, you'll still have to turn down your Java security settings for it to work. Or you could just jar with an older update of Java. Edited by Hope

Share this post


Link to post
Share on other sites
  • 0
I've done some researching, and this seems to be a security issue that needs to be fixed by the provider, so sadly, there is really only one thing you can do.

You'll have to uninstall that current version, and re-install an earlier version of Java.

And if you would like a video of how to do the above, posted by Hope, go here.
[url]https://www.youtube.com/watch?v=_mDVFrFjWVw[/url] this video shows how to turn down the security settings. Edited by Mitchell

Share this post


Link to post
Share on other sites
  • 0
Right, ok. So there's no other way around this other than uninstalling and reinstalling an older version of java? Also I've turned all of my security settings down and added site exceptions but this still happens. Now that I've done the other thing to the webclient which you recommended I now get this error:

Java Plug-in 10.51.2.13
Using JRE version 1.7.0_51-b13 Java HotSpot(TM) Client VM
User home directory = B:\Users\Dinny
----------------------------------------------------
c: clear console window
f: finalize objects on finalization queue
g: garbage collect
h: display this help message
l: dump classloader list
m: print memory usage
o: trigger logging
q: hide console
r: reload policy configuration
s: dump system and deployment properties
t: dump thread list
v: dump thread stack
x: clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------
CacheEntry[[url]http://project-hallucination.com/@ProjectHallucinationWebClient.jar]:[/url] updateAvailable=true,lastModified=Thu May 22 03:37:37 BST 2014,length=465710
0

Share this post


Link to post
Share on other sites
  • 0
I've figured out an easier way.

Go to your Java Control panel and add that specific URL that has the Webclient, [url]http://project-hallucination.com/webclient.html[/url] , to the 'edit site list' located under the 'Security' tab. Add that URL to it above and reload the page and that should completely fix your issue.

Share this post


Link to post
Share on other sites
  • 0
I've already done this and for some reason it doesn't work.

Share this post


Link to post
Share on other sites
  • 0
I assume you lowered your security settings on top of that as well.

Hmph. I am not 100% sure then. [MENTION=35144]Hope[/MENTION], do you have anything?

[COLOR="silver"]- - - Updated - - -[/COLOR]

I assume you lowered your security settings on top of that as well.

Hmph. I am not 100% sure then. [MENTION=35144]Hope[/MENTION], do you have anything?

Share this post


Link to post
Share on other sites

×