Jump to content
  • 0
Sign in to follow this  
yamitheninja

compiler error please help

Question

im trying too get my compiler to work and it wont. when I go to compile it says :
unrecognized option: -d
error: could not create the java virtual machine.
error: a fatal exception has occurred. program will exit.
press any key to continue. . .

any ideas on what it is?

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
post the code that you have inside your compiler

Share this post


Link to post
Share on other sites
  • 0
watch ur jdk most likely isn't ur jdk updated in ur compiler.

if u dont know where to find ur jdk than i can explain for windows 7.

go to "computer/ C; / users/ program files/ java" than u see like "jdk1.7.0_51" (at least this is the jdk version i have this can be something else than u have" now to fix ur problem i see 2 common things that make's this error.

first time for the compiler.

most time's the compiler will say like this,

[MENTION=7458]echo[/MENTION] off
Title Compiler
"C:\Program Files\Java\jdk1.7.0_51\bin\javac.exe" -d ./bin ./src/*.java ./src/sign/*.java
pause
"

but most likely ur jdk version installed on ur computer is differn't just chance that shall fix the error.

There is passble is doesn't says "jdk" but says "jre" than look up ur jre version mine is "7" so for me it shall looked like this,

" [MENTION=7458]echo[/MENTION] off
Title Compiler
"C:\Program Files\Java\jre7\bin\javac.exe" -d ./bin ./src/*.java ./src/sign/*.java
pause
"

but for u it can be "6" if u diddn't updated ur jre version.

Also watch in ur firewall that u allowed jdk(java) else u can have evrything right in ur compiler but that wont ever work whitout chancing settings in ur firewall.

for that fellow the next steps.

1. go to ur computer.
2. go to system properties.
3. go to advanced system settings
4. than go to environment variable.
5. than u get a little screen that will say on top "environment variable" and little under it shall say something like "user variable for (user)"

than u see the fellowing options.

"new/edit/deleate"

6. press new, than it has 2 text bar's something about a name, put there "classpath" the other 1 left there u put "C:\Program Files\Java\jdk ur jdk\bin;%CLASSPATH%; " where i putted there "ur jdk" there u need to put something like "jdk1.7.0_51" if u have atleast that version.

than press okay.

7. do the same again, make a other new one but this time u dont put into the top text bar "classpath" but now u do "path" the other text bar is the same whit ur jdk version into in.

i hope i helped out whit this.

Edit: btw. if this helped ur out or not please reply so i know if it helped :D if not please tell more or post a picture from ur compiler that shows the error and a picture of ur compiler when u do "edit" Edited by darkchaos

Share this post


Link to post
Share on other sites
  • 0
[quote name='darkchaos']watch ur jdk most likely isn't ur jdk updated in ur compiler.

if u dont know where to find ur jdk than i can explain for windows 7.

go to "computer/ C; / users/ program files/ java" than u see like "jdk1.7.0_51" (at least this is the jdk version i have this can be something else than u have" now to fix ur problem i see 2 common things that make's this error.

first time for the compiler.

most time's the compiler will say like this,

[MENTION=7458]echo[/MENTION] off
Title Compiler
"C:\Program Files\Java\jdk1.7.0_51\bin\javac.exe" -d ./bin ./src/*.java ./src/sign/*.java
pause
"

but most likely ur jdk version installed on ur computer is differn't just chance that shall fix the error.

There is passble is doesn't says "jdk" but says "jre" than look up ur jre version mine is "7" so for me it shall looked like this,

" [MENTION=7458]echo[/MENTION] off
Title Compiler
"C:\Program Files\Java\jre7\bin\javac.exe" -d ./bin ./src/*.java ./src/sign/*.java
pause
"

but for u it can be "6" if u diddn't updated ur jre version.

Also watch in ur firewall that u allowed jdk(java) else u can have evrything right in ur compiler but that wont ever work whitout chancing settings in ur firewall.

for that fellow the next steps.

1. go to ur computer.
2. go to system properties.
3. go to advanced system settings
4. than go to environment variable.
5. than u get a little screen that will say on top "environment variable" and little under it shall say something like "user variable for (user)"

than u see the fellowing options.

"new/edit/deleate"

6. press new, than it has 2 text bar's something about a name, put there "classpath" the other 1 left there u put "C:\Program Files\Java\jdk ur jdk\bin;%CLASSPATH%; " where i putted there "ur jdk" there u need to put something like "jdk1.7.0_51" if u have atleast that version.

than press okay.

7. do the same again, make a other new one but this time u dont put into the top text bar "classpath" but now u do "path" the other text bar is the same whit ur jdk version into in.

i hope i helped out whit this.

Edit: btw. if this helped ur out or not please reply so i know if it helped :D if not please tell more or post a picture from ur compiler that shows the error and a picture of ur compiler when u do "edit"[/QUOTE]

very detailed, thanks you. but im on windows 8 and ill try what u said

Share this post


Link to post
Share on other sites
Sign in to follow this  

×