Jump to content
  • 0
Sign in to follow this  
PouchOfLemons

Home Teleport Button Doesn't Work

Question

Hello everyone. As my title states, my Home Teleport button isn't working. It just won't work. My code should be correct, see for yourself:
[CODE]case 50056:
String type = c.playerMagicBook == 0 ? "modern" : "ancient";
c.getPA().startTeleport(Config.EDGEVILLE_X, Config.EDGEVILLE_Y, 0,
type);
break;[/CODE]
It won't even teleport me anywhere. I click the button and it does nothing. However, my other teleport buttons work. This is really strange, could anyone help?
Thanks. Edited by PouchOfLemons

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
Make sure you have the correct button ID and not some other one.

If you are positive it is the right button ID give an example of a working teleport.

Share this post


Link to post
Share on other sites
  • 0
[quote name='Rog3r']Make sure you have the correct button ID and not some other one.

If you are positive it is the right button ID give an example of a working teleport.[/QUOTE]
How can I check that?

Share this post


Link to post
Share on other sites
  • 0
goto the clickingbuttons.java file
click on the home tele button so it shows you the actionButton ID in the cmd prompts.

then add in clickingbuttons.java
case xxxx: (where xxxx is your actionButton ID)
TeleportHandler.teleport(p, 3005, 3849, 0, "auto"); //this may be different for you but isnt hard to find and x coords = 3005 y coords = 2849
break;

Share this post


Link to post
Share on other sites
Sign in to follow this  

×