Jump to content
hessel

All private servers run slow

Recommended Posts

Hi guys,

I like to play Runescape/RSPS in high detail, but it lags badly :/
The specs of my computer:
AMD Radeon HD 7770 graphics card
Intel Core i5 2310 CPU
16GB DDR3-1333MHz RAM
Asus Maximus IV Gene-Z Motherboard
Intel 60GB 520 series SSD
500GB HDD

Why cant i run Runescape in high detail??

Share this post


Link to post
Share on other sites
put it on medium graphics and you'll be fine. (:


Or just change color scheme to basic on your computer, makes it faster.

using Firefox or internet explorer?

Share this post


Link to post
Share on other sites
Try changing the graphics driver thingy (Should have Safe mode, OpenGL, Direct X etc)

Try toggling between them and see if it improves it.

Share this post


Link to post
Share on other sites
[quote name='Nighthawk123']put it on medium graphics and you'll be fine. (:


Or just change color scheme to basic on your computer, makes it faster.

using Firefox or internet explorer?[/QUOTE]

I don't think that graphics resolution is the problem with his graphic card. Have you installed the drivers that came with the card?

Share this post


Link to post
Share on other sites
I can guarantee it's not his graphics card. I have a Radeon HD 4850 and I can run RS on high quality with no problems at all. What sort of lag are you getting?

Share this post


Link to post
Share on other sites
[quote name='Ziek`']I can guarantee it's not his graphics card. I have a Radeon HD 4850 and I can run RS on high quality with no problems at all. What sort of lag are you getting?[/QUOTE]

Yea, I can even do this with integrated graphics.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×