Jump to content
  • 0
Sign in to follow this  
Stxalth

Player disappear?

Question

Okay, so I finally made my first custom model and it was success! The inventory/drop model is excellent. However, when I tried to wear the Cape I made the player disappears? Does anyone know what is wrong? How can I fix it?

Share this post


Link to post
Share on other sites

29 answers to this question

Recommended Posts

  • 0
Its probably a problem with your ints OR you didn't make the model properly for equipping, either way give me the ints?

Share this post


Link to post
Share on other sites
  • 0
I think its the ints. I'm not really sure how to do some of them but here they are:
if(i == 13676)
{
class8.aStringArray189 = new String[5];
class8.aStringArray189[1] = "Wear";
class8.anInt174 = 13675;
class8.anInt181 = 2000;
class8.anInt190 = 572;
class8.anInt198 = 0;
class8.anInt204 = 0;
class8.anInt169 = 0;
class8.anInt194 = 1;
class8.anInt165 = 13676;
class8.anInt200 = 13676;
class8.anInt175 = -1;
class8.anInt197 = -1;
class8.anInt199 = -1;
class8.aString170 = "Pk cape";
class8.aByteArray178 = "A Cape crafted by Ajax.".getBytes();
}
Are they right?

Share this post


Link to post
Share on other sites
  • 0
this was copied straight from the thread you got the model from correct? also what revision are you using.

Share this post


Link to post
Share on other sites
  • 0
Nope, I had to copy the ints from another cape "Owner Cape" and changed the "Model" ints. I use Notepad/Notepad++.

Share this post


Link to post
Share on other sites
  • 0
alright you may have gotten the equip model mixed up with one of the others who knows , but this is for a 317 right,.

Share this post


Link to post
Share on other sites
  • 0
Yes 317. And no I put it in "Item.java" under "Capes" and next to "Owner Cape".

Share this post


Link to post
Share on other sites
  • 0
No I put the correct Model ID under the correct "Equip" section. I put the ints in "Class8.java". Do you know if I put the ints in right?

Share this post


Link to post
Share on other sites
  • 0
it can depend where in class8.java you put the ints, and model ID in the equip section?... shouldn't have anything to do with models..

Share this post


Link to post
Share on other sites
  • 0
Nevermind the "Item.java" stuff - I put the ints right before Cape Model "13677" and my Cape Model is "13676

Share this post


Link to post
Share on other sites
Sign in to follow this  

×