Jump to content

The RuneLocus forum has been archived and does not accept new registrations.
Click here for more information, and click here to join the community on Discord.

20th April 2018


Cart
 Share

Recommended Posts

  • Updated various plugins to the latest version (including one that suffered from an XSS vulnerability).
  • 4.3.0 of IPB is here, I am currently waiting for every plugin and application to be 4.3 compatible before updating. 
  • Users can no longer rate their own topic.
Link to comment
Share on other sites

  • 1 month later...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...