Jump to content
Chronicscape

[831+] Yggdrasil

Recommended Posts

[I completly restarted eclipse, and both login and game server, using 831 cache]

When i start my client via Eclipse, i pass checking updates reach fetching and get to 92% i get quick lagg then at 97% i get this error.

Error: jagex.Class217.method3081:26 jagex.Class531.executeCs2:44 jagex.Class281.method3798:65 jagex.Class627.method7475:146 jagex.Class536.method6382:58 jagex.Class192.method2911:346 jagex.Class255_Sub1.method8247:52 jagex.client.method6932:3006 jagex.Class584.method6918:590 jagex.Class584.method6898:200 jagex.Class584.run:168 java.base/java.lang.Thread.run | java.lang.RuntimeException:  3956 |  0,0,0,0 0,0,0, 0 0 2 1024,561 1 2 1 1 0 0 1909 8 7628 0irU8SxE4on1Tl9/y7sxdiPtbP2kt8WC
java.net.ConnectException: Connection refused: connect
    at java.base/java.net.DualStackPlainSocketImpl.connect0(Native Method)
    at java.base/java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
    at java.base/java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
    at java.base/java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
    at java.base/java.net.AbstractPlainSocketImpl.connect(Unknown Source)
    at java.base/java.net.PlainSocketImpl.connect(Unknown Source)
    at java.base/java.net.Socket.connect(Unknown Source)
    at java.base/java.net.Socket.connect(Unknown Source)
    at java.base/sun.net.NetworkClient.doConnect(Unknown Source)
    at java.base/sun.net.www.http.HttpClient.openServer(Unknown Source)
    at java.base/sun.net.www.http.HttpClient.openServer(Unknown Source)
    at java.base/sun.net.www.http.HttpClient.<init>(Unknown Source)
    at java.base/sun.net.www.http.HttpClient.New(Unknown Source)
    at java.base/sun.net.www.http.HttpClient.New(Unknown Source)
    at java.base/sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source)
    at java.base/sun.net.www.protocol.http.HttpURLConnection.plainConnect0(Unknown Source)
    at java.base/sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)
    at java.base/sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source)
    at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
    at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
    at java.base/java.net.URL.openStream(Unknown Source)
    at jagex.Class640.method7592(Class640.java:104)
    at jagex.Class584.run(Class584.java:172)
    at java.base/java.lang.Thread.run(Unknown Source)
error_game_crash
 

Share this post


Link to post
Share on other sites

Those are warnings which are fine. What you are having an issue with is the client IP. Or it could be the cache placement/naming. How is it all set up? Yggdrasil831 should be the cache folder name in your user folder like how mine would ne Users\kingo\.

Share this post


Link to post
Share on other sites

ohhhhhh c i had my cache at C:/

 

I'll fix that and see how it works out, :)

Share this post


Link to post
Share on other sites

having an issue upon getting past 97% then crash.

 

Error: jagex.Class217.method3081:26 jagex.Class531.executeCs2:44 jagex.Class281.method3798:65 jagex.Class627.method7475:146 jagex.Class536.method6382:58 jagex.Class192.method2911:346 jagex.Class255_Sub1.method8247:52 jagex.client.method6932:3006 jagex.Class584.method6918:590 jagex.Class584.method6898:200 jagex.Class584.run:168 java.lang.Thread.run | java.lang.RuntimeException:  3956 |  0,0,0,0 0,0,0, 0 0 2 1024,741 1 2 1 1 0 0 3635 8 16349 0irU8SxE4on1Tl9/y7sxdiPtbP2kt8WC
java.io.IOException: Server returned HTTP response code: 503 for URL: http://127.0.0.1/clienterror.ws?c=831&cs=1&u=0&v1=Oracle+Corporation&v2=1.8.0_151&e=jagex.Class217.method3081%3A26+jagex.Class531.executeCs2%3A44+jagex.Class281.method3798%3A65+jagex.Class627.method7475%3A146+jagex.Class536.method6382%3A58+jagex.Class192.method2911%3A346+jagex.Class255_Sub1.method8247%3A52+jagex.client.method6932%3A3006+jagex.Class584.method6918%3A590+jagex.Class584.method6898%3A200+jagex.Class584.run%3A168+java.lang.Thread.run+%7C+java.lang.RuntimeException%3A++3956+%7C++0%2C0%2C0%2C0+0%2C0%2C0%2C+0+0+2+1024%2C741+1+2+1+1+0+0+3635+8+16349+0irU8SxE4on1Tl9%2Fy7sxdiPtbP2kt8WC
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
    at java.net.URL.openStream(Unknown Source)
    at jagex.Class640.method7592(Class640.java:104)
    at jagex.Class584.run(Class584.java:172)
    at java.lang.Thread.run(Unknown Source)
error_game_crash

 

 

 

Is it because im not using no-ip? I currently have my public ip set for the server and the client tries loading via 127.0.0.1 (which is intended for testing) 

 

Edited by Xplodin
It crashed at 97% and shown this error, not crashing at 99

Share this post


Link to post
Share on other sites
On 1/16/2018 at 7:16 PM, Xplodin said:

having an issue upon getting past 97% then crash.

 

Error: jagex.Class217.method3081:26 jagex.Class531.executeCs2:44 jagex.Class281.method3798:65 jagex.Class627.method7475:146 jagex.Class536.method6382:58 jagex.Class192.method2911:346 jagex.Class255_Sub1.method8247:52 jagex.client.method6932:3006 jagex.Class584.method6918:590 jagex.Class584.method6898:200 jagex.Class584.run:168 java.lang.Thread.run | java.lang.RuntimeException:  3956 |  0,0,0,0 0,0,0, 0 0 2 1024,741 1 2 1 1 0 0 3635 8 16349 0irU8SxE4on1Tl9/y7sxdiPtbP2kt8WC
java.io.IOException: Server returned HTTP response code: 503 for URL: http://127.0.0.1/clienterror.ws?c=831&cs=1&u=0&v1=Oracle+Corporation&v2=1.8.0_151&e=jagex.Class217.method3081%3A26+jagex.Class531.executeCs2%3A44+jagex.Class281.method3798%3A65+jagex.Class627.method7475%3A146+jagex.Class536.method6382%3A58+jagex.Class192.method2911%3A346+jagex.Class255_Sub1.method8247%3A52+jagex.client.method6932%3A3006+jagex.Class584.method6918%3A590+jagex.Class584.method6898%3A200+jagex.Class584.run%3A168+java.lang.Thread.run+%7C+java.lang.RuntimeException%3A++3956+%7C++0%2C0%2C0%2C0+0%2C0%2C0%2C+0+0+2+1024%2C741+1+2+1+1+0+0+3635+8+16349+0irU8SxE4on1Tl9%2Fy7sxdiPtbP2kt8WC
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
    at java.net.URL.openStream(Unknown Source)
    at jagex.Class640.method7592(Class640.java:104)
    at jagex.Class584.run(Class584.java:172)
    at java.lang.Thread.run(Unknown Source)
error_game_crash

 

 

 

Is it because im not using no-ip? I currently have my public ip set for the server and the client tries loading via 127.0.0.1 (which is intended for testing) 

 

How are you trying to run it really? Ports open? And which IPs did you change? Changing the wrong one could result in this issue.

Share this post


Link to post
Share on other sites

I also want to to give a try to the code (I have Java programming skills), but can't download from the link including the cache from Mega because the file is too big. Is any other method for downloading? (Mega Downloader and JDownloader can't bypass the Mega limit nowadays.

Edited by Azeri

Share this post


Link to post
Share on other sites
5 hours ago, Azeri said:

I also want to to give a try to the code (I have Java programming skills), but can't download from the link including the cache from Mega because the file is too big. Is any other method for downloading? (Mega Downloader and JDownloader can't bypass the Mega limit nowadays.

Tha just means you have exceeded the free daily limit. Try again.

Share this post


Link to post
Share on other sites
On 1/24/2018 at 9:01 PM, Chronicscape said:

How are you trying to run it really? Ports open? And which IPs did you change? Changing the wrong one could result in this issue.

I tried running default localhost (127.0.0.1) and my public IP

Ports are forwarded correctly as well. The only IPs changed were those in the server settings and the one in the client.

Downloading the cache you sent now and will update if it fixes the issue.

 

Works perfect now. Thank you 

Edited by Xplodin
Works now

Share this post


Link to post
Share on other sites
On 5/21/2017 at 2:36 PM, Chronicscape said:

For a while I have been running servers, helping others and had a great time doing so. I am here today to release my 831+ client/server package. Only thing you will need to find is a cache as I don't want to include mine.

I am also doing this as there are no stable 831s and the fact that I got tired of working on it solo with people who said would help me but didnt want to lol. So please do enjoy!

Please login or register to see this code.

Please login or register to see this link.

Please login or register to see this link.

Please login or register to see this link.

Please login or register to see this link.

Please login or register to see this link.

Please login or register to see this link.

Please login or register to see this link.

Please login or register to see this link.

Please login or register to see this link.

Let me know if Mega stops working.

Hey buddy,

So I'm getting a java.lang.OutOfMemoryException everytime the server runs for a few minutes. Any idea what might be causing this?

Edited by Zero RS

Share this post


Link to post
Share on other sites
On 2/2/2018 at 1:03 PM, Zero RS said:

Hey buddy,

So I'm getting a java.lang.OutOfMemoryException everytime the server runs for a few minutes. Any idea what might be causing this?

You need more RAM or gotta allocate less. When starting the server, reduce the xmx number in the batch file to 1024M and see if that helps 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×