Jump to content

The RuneLocus forum has been archived and does not accept new registrations.
Click here for more information, and click here to join the community on Discord.

Search the Community

Showing results for tags 'xtea'.

The search index is currently processing. Current results may not be complete.
  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • RuneLocus
    • News & Announcements
    • Information Booth
    • Website Support
    • Introductions
    • Chat
    • Forum Games
  • RuneScape Development
    • RSPS General
    • RuneScape Private Server (RS2)
    • RuneScape Private Server (503+)
    • RuneScape Private Server (EoC 742+)
  • Other
    • Digital Art
    • Gaming
    • Webdevelopment
    • Computers
  • Marketplace
    • RuneScape Market
    • RSPS Market
    • Others Market
    • Freelance Middleman Services
  • Super Secret Club's Topics

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 1 result

  1. I've been attempting to load the 474 landscape objects in my 498 Arios client/server without much luck. So far, I've tried the following: - Just directly copying map file 382 and 383 (Lumbridge) from the 474 cache using Harlan's Cache Manager * Result: Ground tiles work as expected because there is no XTEA encryption, but all objects fail to load within the affected region, and the console outputs invalid XTEA errors - all other regions work - Copy the 'decryptXtea' function from the 474 client deob into my 498 client, and use the 474 XTEA decrypt code when the 383 file is being processed * Result: Invalid GZIP header error, Invalid XTEA errors, and the rest of the other chunks fail to load their objects, too - GZipped the 383 file before putting it into the 498 cache * Result: When logging in, the loading bar gets to 31% and freezes with null reference errors in the console - Changed XTEAs for region 12850 (Lumbridge) and re-packed the packed.mxk file, but there was no change (These keys could be wrong, they come from a random "474 XTEAs.txt" file I downloaded at some point.) * Result: Same as the first result (no objects appear + invalid XTEA errors) - Tried XTEAs set to 0,0,0,0 for region 12850 in the packed.mxk file * Result: Same as the first result (no objects appear + invalid XTEA errors) - Tested to ensure Harlan's Cache Manager isn't corrupting the files by replacing the 383 file in my 498 cache with itself * Result: The 498 objects for map 383 load without error (so it isn't the cache manager messing it up) I'm not sure what else to try, am I forgetting a vital or obvious step? I could use another revision besides 474, so long as it looks similar to how Runescape looked just before or after the grand exchange was added. My ultimate goal is to re-create Runescape like it was around 2006/2007, but with full screen. I'm trying to match the experience of RS by recording all of the quests + all possible chat dialogues from OSRS, and manually re-creating missing content that the Arios team didn't get to. The landscape content in Arios 498 isn't as old as I'd like RS to look, but I also really like the server structure they already wrote so I'd like to just downscale my Arios 498 landscape to 474 or similar. Thank you for reading.
×
×
  • Create New...