Jump to content

Search the Community

Showing results for tags 'models'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • RuneLocus
    • News & Announcements
    • Information Booth
    • Website Support
    • Introductions
    • Chat
    • Forum Games
  • RuneScape Development
    • RSPS General
    • RuneScape Private Server (RS2)
    • RuneScape Private Server (503+)
    • RuneScape Private Server (EoC 742+)
  • Other
    • Digital Art
    • Gaming
    • Webdevelopment
    • Computers
  • Marketplace
    • RuneScape Market
    • RSPS Market
    • Others Market
    • Freelance Middleman Services
  • Super Secret Club's Topics

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Found 106 results

  1. shershah1

    Varago models?

    Where can i find the varago models or the full package? Can someone provide a link. Very appriciated. Thanks
  2. Hello, I've tried to add some items to my server (chaotics and such) and I've done everything correctly as the tutorial said. But when i try to load my client it gives this error : [attachment=39:error101.jpg] Any help would be appreciated!
  3. Hello i need help unpacking/packing my cache, also need help with adding item models & boss models, i will pay with osrs cash if you actually help me learn :)
  4. Kill Joy

    Custom Models

    A friend of mine needs 5-10 custom models made. PM me or post if you can do this.
  5. Been working on some customs but i got to have the character model to down scale them... anyone mind on sharing? You can pm me also if you dont want anyknow knowing. Thanks!
  6. King Motti

    Tetsu Models

    So yeah, I've found Seasinger's & Deathlotus models which work. But somehow i cant find Tetsu models. Do someone have them and want to share ?
  7. I am looking for anyone who would know or has a program that can get the data for objects at what model they use for example Mithril seed flowers the objects that pop up after planting are 2980-2988. I would like to know which models they use for my next project.
  8. sbain9395

    Adding models

    hey im not sure how to add models.. im working with tyreatta 317 pi so if u can help please add me on skype -- skype name: worthyman3
  9. Hey guys, I'm using Swe prime source and client But i have a few problems with adding some custom items I added the int's on Customitems.java (itemDef). But they are no place on the cache to add the models .Dat files Can anyone help me please. Thanks.
  10. I've added new models cache packed, now when I start my client, it gets stuck at requesting models. Yes my models are in .gz form. How can I fix this and if you need me to post any codes, I will.
  11. As the title says it all, I am looking for someone who can help me with this. We can discuss more details through Skype if your interested. You guys may say "Look around there are models roaming around" but understand that I have. I been looking for a few days here and there and could not find any. Like I said before if you need more details we can discuss it over Skype. Your time won't be wasted. I currently have these character models [img]http://i.imgur.com/4FuCDMK.png[/img] I want to change it to these models [img]http://i.imgur.com/qOLZ3tj.png[/img]
  12. if anybody knows what are the vine whip's appropiate id models please comment because i really need this... thanks :D
  13. I'm having some troubles finding a link for the models that hasn't been taken down. Does anyone have them laying around by chance? Thanks in advance. EDIT: Found some finally, link for anyone else that needs: [url]http://www.************.org/runescape-development/rs2-client/models/560913-pvp-armour-chaotics-nex-armours-spiriit-shields-adding-new-model-header-rel.html[/url] (r-server)
  14. VictorRwh

    Adding models

    Hello, I'm making a server and I've added some models from another source. I also added the item names to items.cfg and the model codes to class8.java But still the items I've added wont shop up as the models. What am I doing wrong? :S Victor
  15. Red122

    Adding models help

    hey guys i have recently started coding a 317 blank delta and i am trying to add models. I put the gzip files in the "models" folder and put the int into the class 8 but when i compile and get in i cannot add them. I have tried almost every form of "addmodel ****" and "addmodels" ext. Not sure what to do any suggestions would be greatly appreciated! Thank you in advanced!
  16. So as the title suggest my custom models are not loading. I'm fair sure it has to do with either the model being broken/corrupt(although you can open it up in a model editor just fine), that the model loader is outdated(which i have no idea where to even begin upgrading it) or something else that I haven't considered/known of. Callisto example: What it looks like currently in game: [url]http://imgur.com/LJSZaos[/url] EntityDef.java code: [CODE] case 9000: entityDef.actions = new String[5]; entityDef.actions[1] = "Attack"; entityDef.anIntArray94 = new int[1]; entityDef.anIntArray94[0] = 13245; //ID of .dat File entityDef.anInt77 = 4919; //STAND ANIM entityDef.anInt67 = 4923; //WALK ANIM entityDef.combatLevel = 470; entityDef.name = "Callisto"; entityDef.description = "I wouldn't want to eat his Porridge.".getBytes(); break;[/CODE] Code in client.java(client sided): [CODE] drawLoadingText(60, "Connecting to update server"); onDemandFetcher = new OnDemandFetcher(); onDemandFetcher.start(streamLoader_6, this); Model.method459(onDemandFetcher.getModelCount(), onDemandFetcher); preloadModels(); //THIS LINE //models(); drawLoadingText(80, "Unpacking media"); [/CODE] and : [CODE] public void preloadModels() { File file = new File("./cache/Raw/"); File[] fileArray = file.listFiles(); for(int y = 0; y < fileArray.length; y++) { String s = fileArray[y].getName(); byte[] buffer = ReadFile("./cache/Raw/"+s); Model.method460(buffer,Integer.parseInt(getFileNameWithoutExtension(s))); System.out.println("Loaded model " + y); } } [/CODE] The console output prints out that its loaded Callisto's file... code in Model.method460: [CODE] public static void method460(byte abyte0[], int j) { //Items //boolean newFormat = abyte0[abyte0.length - 1] == -1 && abyte0[abyte0.length - 2] == -1; if(abyte0 == null) { Class21 class21 = aClass21Array1661[j] = new Class21(); class21.anInt369 = 0; class21.anInt370 = 0; class21.anInt371 = 0; return; } Stream stream = new Stream(abyte0); stream.currentOffset = abyte0.length - 18;//(!newFormat ? 18 : 23); Class21 class21_1 = aClass21Array1661[j] = new Class21(); class21_1.aByteArray368 = abyte0; class21_1.anInt369 = stream.readUnsignedWord(); class21_1.anInt370 = stream.readUnsignedWord(); class21_1.anInt371 = stream.readUnsignedByte(); int k = stream.readUnsignedByte(); int l = stream.readUnsignedByte(); int i1 = stream.readUnsignedByte(); int j1 = stream.readUnsignedByte(); int k1 = stream.readUnsignedByte(); //if (newFormat) { // int ignore = stream.readUnsignedByte(); // } int l1 = stream.readUnsignedWord(); int i2 = stream.readUnsignedWord(); int j2 = stream.readUnsignedWord(); int k2 = stream.readUnsignedWord(); // if (newFormat) { // int ignore = stream.readUnsignedByte(); // } int l2 = 0; class21_1.anInt372 = l2; l2 += class21_1.anInt369; class21_1.anInt378 = l2; l2 += class21_1.anInt370; class21_1.anInt381 = l2; if(l == 255) l2 += class21_1.anInt370; else class21_1.anInt381 = -l - 1; class21_1.anInt383 = l2; if(j1 == 1) l2 += class21_1.anInt370; else class21_1.anInt383 = -1; class21_1.anInt380 = l2; if(k == 1) l2 += class21_1.anInt370; else class21_1.anInt380 = -1; class21_1.anInt376 = l2; if(k1 == 1) l2 += class21_1.anInt369; else class21_1.anInt376 = -1; class21_1.anInt382 = l2; if(i1 == 1) l2 += class21_1.anInt370; else class21_1.anInt382 = -1; class21_1.anInt377 = l2; l2 += k2; class21_1.anInt379 = l2; l2 += class21_1.anInt370 * 2; class21_1.anInt384 = l2; l2 += class21_1.anInt371 * 6; class21_1.anInt373 = l2; l2 += l1; class21_1.anInt374 = l2; l2 += i2; class21_1.anInt375 = l2; l2 += j2; } [/CODE] I've checked with other client source files and it seems to look pretty much the same. So Im not sure what to do or where to go to come up with my solution as of now. Any links to threads,advice or suggestions would be greatly appreciated.
  17. Following this guide [url]http://www.runelocus.com/forums/showthread.php?75881-Release-TokHaar-Kal-PI[/url] to add kiln cape. I downloaded models and added ints correctly (had to modify ints) models are in the raw folder and the path used is fine, but whenever I place one of the models from the new cape into my raw folder the client crashes when loaded and gives me this error Error: loaderror Connecting to update server 60 These are not first models I have added I have got spirit shields working already with no problems, can anyone help me with this pls? :emb:
  18. When ever I equip my trident of seas or my tentacle whip I turn completely invisible, my models are cache packed. My ints: [CODE]case 15014: itemDef.name = "Trident of the seas"; itemDef.description = "A weapon from the deep." .getBytes(); itemDef.maleEquip1 = 1052; itemDef.femaleEquip1 = 1052; itemDef.modelID = 1051; itemDef.modelRotation1 = 420; itemDef.modelRotation2 = 1130; itemDef.modelZoom = 2755; itemDef.modelOffset2 = 0; itemDef.modelOffset1 = 0; itemDef.actions = new String[5]; itemDef.actions[1] = "Wield"; itemDef.actions[3] = "Check"; break; case 15011: itemDef.name = "Abyssal tentacle"; itemDef.description = "A weapon from the abyss, embedded in a slimy tentacle." .getBytes(); itemDef.modelID = 4185; itemDef.modelZoom = 840; itemDef.modelRotation1 = 280; itemDef.modelRotation2 = 121; itemDef.modelOffset2 = 56; itemDef.actions[1] = "Wield"; itemDef.maleEquip1 = 4186; itemDef.femaleEquip1 = 4186; itemDef.actions[1] = "Wield"; itemDef.actions[4] = "Check"; itemDef.actions[3] = "Dissolve"; break;[/CODE]
  19. moved to : [url]http://www.runelocus.com/forums/showthread.php?101281-Has-anyone-vesta-models-(For-project-insanity)&p=787455#post787455[/url]
  20. Has anyone full vesta models? For 317 server.
  21. After i Extracted .Dat files to RAW folder, It gives me this error, Can anyone help please? [IMG]http://i.imgur.com/oXmKcKt.png[/IMG]
  22. I've added model's before to my server's but it's not working, there was no "Raw" folder in the cache so i made one to put the model's in it like normal, but then there's a model's.dat and a models.idx, and im assumming you need a cache editor for those? if so i've looked and can't find a link working for toms cache suite to even try that, and i've never done it that way before, only through the raw folders, i have all item ints and entiry def ints correct, compile no errors, but the items won't show, please someone help me out with this one, please and thankyou
  23. shershah

    Drygore models id

    Can sombody give me the following drygore model ids For drygore rapier: Inventory zoom: Inventory model: Male equip Model Equip ID 1: Female model equip ID 1: Male equip Model Equip ID 2: Female model equip ID 2: Male equip Model Equip ID 3: Female model equip ID 3: For drygore longsword: Inventory zoom: Inventory model: Male equip Model Equip ID 1: Female model equip ID 1: Male equip Model Equip ID 2: Female model equip ID 2: Male equip Model Equip ID 3: Female model equip ID 3: For drygore mace: Inventory zoom: Inventory model: Male equip Model Equip ID 1: Female model equip ID 1: Male equip Model Equip ID 2: Female model equip ID 2: Male equip Model Equip ID 3: Female model equip ID 3: Would be very aprriciated by me and my server. Thanks
  24. Okey, so I'm using the Extreme KO source and I've found a very annoying thing. [url]http://imgur.com/lHJ6qb3[/url] [ATTACH=CONFIG]10172[/ATTACH]¨ as you can see the regular rapier is glitched out, same with the Chaotic Longsword and SOMETIMES the fire cape. I find this really annoying and I have no idea whats wrong, the thing is, I've tried several different clients and it's the same model for the regular rapier as the broken one. Does anyone got a solution for this?
  25. Just Made a Custom Iron Plate body but on the tut that showed me how it says to paste my zipped file into my clients models folder but i dont have a folder in my client named models. not sure where to put it, would it be okay to make a new folder called models and just proceed with that?
×