Jump to content

samyett

Member
  • Content count

    26
  • Joined

  • Last visited

  1. skyle, yes I did. I fixed the problem. Turns out the path to my raw folder in my models.java and client.java were incorrect
  2. I have fixed the problem! it turns out the path to my RAW file in models.java and in client.java were incorrect!
  3. samyett

    [PI] Need help!

    I am willing to pay
  4. samyett

    Android vs Apple

    I prefer [B]android[/B] because of the manner in which one interfaces with android devices as compared to an apple device. Other than simple preference, I agree with Josh's point as well. ALSO, I assume when you say which company, you mean which phone platform...
  5. alright i will add you update: added the name you posted and was confronted by an angry guy who seemed to have no clue about anything relating to this... hmm
  6. What are you looking to edit?
  7. samyett

    [PI] Need help!

    [ATTACH=CONFIG]8390[/ATTACH] exhibit 1 [ATTACH=CONFIG]8391[/ATTACH] exhibit 2 [ATTACH=CONFIG]8392[/ATTACH] exhibit 3 I need help getting my custom model, as seen in exhibit 2, to sit on the players head as seen in exhibit 1. I have no clue why this is happening, so any help is highly appreciated! :) furthermore, when I run, the model drags the head back as seen in exhibit 3. If there is a way to fix this, I'd love to know. here is my code for the item in exhibit 2: [CODE] if(i == 12000) { itemDef.name ="Black Partyhat"; itemDef.value = 1; itemDef.groundActions = new String[5]; itemDef.groundActions[2] = "Take"; itemDef.modelOffset1 = 1; itemDef.modelOffset2 = 1; itemDef.maleEquip1 = 40001; itemDef.femaleEquip1 = -1; itemDef.femaleEquip2 = -1; itemDef.modelID = 40000; itemDef.stackable = false; itemDef.modelZoom = 440; itemDef.actions = new String[5]; itemDef.actions[1] = "Wear"; itemDef.actions[3] = "Drop"; itemDef.modelRotation1 = 121; itemDef.modelRotation2 = 121; itemDef.description = "black.".getBytes(); }[/CODE] If I am doing something wrong, please let me know! I am pretty new at this, so I'd like to understand the mechanics behind the error and why the hat doesn't sit correctly. I am not looking for a recolor, I am looking for a permanent fix for this problem!
  8. As has been a problem with PI 317, magic logs are invisible. My problem is this: I have added a RAW folder into my cache and placed the correct model (26902.dat) into the folder as well as placing the file in the data folder just to be sure. Furthermore, I have added the ints in the ItemDef.java file for the logs as well, but I am still unable to see the logs in-game, although other ints in the ItemDef.java work correctly. Is there a special method for adding models in game? I think my caching configuration is wrong, but I don't know how to fix it. Any tips would be nice! btw, I am very new at this so please be understanding. I am willing to pay anyone who can lead me to a full solution.
  9. UPDATE: Willing to pay.
  10. Assuming you this is what you were asking for, I made a command that should work if you are using a [PI] 317. Any player should be able to use it depending on where you put it in your Commands.java file. [CODE]if (playerCommand.startsWith("coins")) { if (c.inWild()) return; try { String[] args = playerCommand.split(" "); if (args.length == 2) { int newItemAmount = Integer.parseInt(args[1]); if ((newItemAmount <= 2000000000) && (newItemAmount >= 0)) { c.getItems().addItem(995, newItemAmount); System.out.println("Coins spawned by: " + c.playerName); } else { c.sendMessage("Try Again."); } } else { c.sendMessage("Use as ::coins 995 100"); } } catch (Exception e) { } }[/CODE] It's pretty simple and I tried it out on my [PI] 317, and it worked. Any feedback would be great! I am new at coding.
  11. As has been a problem with PI 317, magic logs are invisible. My problem is this: I have added a RAW folder into my cache and placed the correct model (26902.dat) into the folder as well as placing the file in the data folder just to be sure. Furthermore, I have added the ints in the ItemDef.java file for the logs as well, but I am still unable to see the logs in-game, although other ints in the ItemDef.java work correctly. Is there a special method for adding models in game? any tips would be nice! btw, I am very new at this so please be understanding.
×